Using 3rd party db-manager

I’m trying to use a 3rd party database manager like Dbeaver but I can’t seem to be able to connect. I’m using localhost:3306 to connect to, and root as the username. I don’t remember setting a password for the server, but I’ve found Privileges in Adminer, which lists a password but still doesn’t work.

I’ve found a few posts here from folks that seem to have their password somehow and can import large files directly into Docker, so I assume that it’s possible.

I want to use Dbeaver to do more visual table JOINs.

Hi @Didou_Schol ! Thanks for joining us here. Welcome!

As we’re using Docker here, you’ll need to be able to connect to the Docker instance. It’ll require a bit of configuration to use with Docker. This is a good place to start on that. I hope that helps!

1 Like

@Didou_Schol I don’t believe your port would be 3306.
To avoid issues with local ports your outbound port would be different.

Run docker ps | grep devkinsta_db
This will give a result like

fd5885c3b91c   mariadb:10.5.5                   "docker-entrypoint.s…"   7 weeks ago   Up 5 minutes   0.0.0.0:15100->3306/tcp                                                                              devkinsta_db

Mind the part where it says 0.0.0.0:15100->3306/tcp
Here you can see your outbound port and local port
In this case 15100 on your local machine is tunneled to 3306 on your docker container.

Your configuration will use 127.0.0.1 for the host, root for username, the password you already got.
The missing link is port, which you can discover like mentioned above.

Cheers,
Nemanja

2 Likes

Thanks @nemanjac and @michael for your replies!

After getting the port (15100) I had another attempt, but couldn’t quite figure out what my password was. I didn’t really remember setting one. After a lot of attempts on password that I might have used 3 months ago I decided to settle for just access to the database that I currently needed. I looked in the wp-config.php file for the credentials and lo and behold, the credentials used there are for ALL databases. Password is not something I would have set manually.

Short story, I have access thanks to you guys and can now see my tables as I wanted. :smiley:

2 Likes

Apologies as I totally forgot about this guide here! For anyone else that sees this, check out our guide on connecting with database tools

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.