Devkinsta port number changed automatically and giving error :report.local unexpectedly closed the connection

Hi, I am facing problem running my local site in kinsta…
The port number automatically changed to https://report.local:51950 and giving error
This site can’t be reached
report.local unexpectedly closed the connection.

It was opening previously but Once started the xampp then the dev kinsta automatically changed the url to - https://report.local:51950/

And page is not opening… Can anyone help me please? I am unable to perform any task and got stuck…

Hello there @Anirudha_Chakrabarty :wave: welcome to DevKinsta community!

This might be due to the default web service ports (80 and 443) are used by other services running on your local computer (might be Apache that’s running by the XMAPP as you mentioned and it used those default ports possibly). Similar to the case as was reported (and resolved) here and here as well.

If that’s the case, you may want to try stop the Apache service (or set it up with different ports other than 80/443 in its config file and re-start the Apache service), and also in DevKinsta → Settings → Port selector, you may want to un-check the “[ ] Auto-detect open ports” and set the HTTP to 80 and HTTPS to 443 (click the Confirm button) and check if you’re able to run your local site at https://report.local

Hopefully that will help to solve the issue you’re experiencing with that custom port thing.

cheers,
Agus

@Agus Thanks… But I can’t find Port selector inside settings…

Thank you for your reply :slight_smile:
Please click on the blue button (on the bottom-left side), that will send you to the Settings page, and on that page, you can scroll down and find the “Port Selector” section.

Cheers,
Agus

@Agus it’s working now… Thanks a lot dear :heart:

1 Like

Awesome! glad to hear that it’s working for you now! :clap: :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.