Windows 10: updating themes/plugins requires FTP creds

Q: DevKinsta Version
A: 1.0.1

Q: OS Version
A: Windows 10 Pro 20H2

Q: Docker Desktop Version
A: 3.1.0

Q: Detailed Description of the Problem
A: After site creation I saw that some default themes and plugins needs to be updated (new versions available). When I click the Update button I’m greeted with this popup:

I don’t know what should I enter there to be able to update that.
I guess permissions should be tweaked or constant added to the wp-config.php file during the WP installation process.

2 Likes

Does this occur on a brand new site or one that you’ve pulled?

On a brand new site created using DevKinsta interface (I’m not a Kinsta customer - yet? - so can’t pull anything).

Thanks @slaFFik . We’ll continue researching this. We haven’t been able to reproduce the issue yet on Windows but we’ll keep looking.

How aboout MacOs? I am experiencing the same issue as slaFFik on MacOS.
I can’t use devKinsta until this is solved since no new plugins can be added or updated.

Same here.
Brand new (multi)site, SSL enabled on Windows 10 pro.

First interaction after logging in was to install a plugin from the WP Repo and was also greeted with entering credentials (as image above).

To fix you can add this line to wp-config.php, which solved my problem.

/** Sets up ‘direct’ method for wordpress, auto update without ftp */
define(‘FS_METHOD’,‘direct’);

6 Likes

Great idea @Didou_Schol . Thanks for the tip. We’ll continue looking into this as well in the meantime.

I can confirm this is happening for me on an imported site from MyKinsta. macOS, M1 with Docker preview.

However, it doesn’t happen on fresh installs.

Not to complicate it at all for you. :smile: