Website Interactivity is Slow

Hi,
I also experience very bad performance: around 7-8 seconds to load a page.
I’m on a MacBook Pro with a M1 pro cpu, running MacOs Monterey. I installed DevKinsta v2.6.
I followed the recommendations of @philippstracker without much success.
Has anyone (Mac user) found a way to make DevKinsta run a little faster?

Also running into this issue

2019 MacBook Pro,
macOS 12.2.1
2.6GHz i7
16GB DDR4 RAM

DevKinsta 2.6.0
Docker 4.3.1

Had no problems with dev kinsta up until a couple of weeks ago I rebuilt my entire dev environment from scratch because of an accidental database deletion locally (when testing migrations) - my first time building an env since ~Feb 2021.

Not sure what’s happened in that time, but pages now taking 40+ seconds to load sometimes, with an average of 20+ seconds overall. It’s kind of completely unworkable and really slows down my ability to be productive. (Production is near-instant when performing similar/the same operations)

Double posting here, but I’ve yet to find any solution - my entire local environment is bricked. It’s not that pages load slowly, they just don’t load now full stop.

I’m effectively prevented from doing my day job because of this for a service that my company is paying for.

Tried re-installing multiple times, updating everything from docker to system OS so that I’m on the latest version, and nothing has worked.

What on earth am I supposed to do about it? The only solution I can think of at this point in time is go away and create my own local staging environment and completely remove the use of DevKinsta within our company’s development process, because there’s no clear fix to this within the forum thread, and no active line of support from Kinsta.

Hi everyone, I’m taking over gathering information for this issue/thread and have been reviewing Windows performance issues this week/advocating for more Mac testing.

For Windows Users: our developers are currently working on prioritizing Hyper-V support over WSL2, since WSL2 is the main cause for performance issues. Right now, Hyper-V sort of works but is not too easy to set up.

For Mac Users: Mac issues seem more complex but less common. Our developers are working to reproduce issues to track down solutions. Right now our advice is to update to Docker Desktop 4.6 then follow Docker’s recommendation to enable “vritiofts.”. If this still does not improve performance for you on Mac, please open a new thread so that we can gather more information for testing purposes.

In the long term, we are looking to change how local files are stored for DevKinsta to hopefully tackle all the performance issues at once. We apologize for how long this has been an issue but we’ll do all we can to make sure we make DevKinsta perform as well as it should. Please feel free to message me privately/directly with any information/issues or create a new thread in the forum so that we can start looking at cases individually. If I discover any new solutions/improvements that can be made I will post them here.

1 Like

@devstagr, can you please start a new Bug Report listing your current versions of everything? Your loading times seem exceptionally high and there may be something else going on besides just the Docker issues.

Sure - fwiw just tried updating docker to the latest version (4.9.1) and enabling vritiofts but no dice still

1 Like

Hi @Kevin & all,
On my end, activating “Enable VirtioFS accelerated directory sharing” works.
Now it’s really fast, loading pages around 50 times faster!
My config:
MacBook Pro 2021 (M1)
macOS Monterey 12.4
Docker 4.9.1
DevKinsta 2.6.0

Thank you!

1 Like