Updating a plugin using zip generates a "Warning: chmod(): Input/output error"

Q: DevKinsta Version
A: I don’t know, the latest one (1.0.2 maybe?). Related feature request.

Q: OS Version
A: Windows 10 Pro 20H2

Q: Docker Desktop Version
A: 3.1.0

Q: Detailed Description of the Problem
A: I used the default WP 5.6+ feature of updating an already installed plugin using a zip file.

I got this error:

Warning: chmod(): Input/output error in /www/kinsta/public/mylocalsite/wp-admin/includes/class-wp-filesystem-direct.php on line 173

WP reported “Plugin updated successfully.”.

:thinking: I wonder if it’s a permissions issue. Is this from an imported site? Could you try the steps highlighted in this thread here and let me know if that helps?

No, this is for a new site created using DK.