"Something Bad Happened" every time I try to make a site

Q: Date/Time this occurred (Provide your time zone also)
A: Always

Q: DevKinsta Version
A: 2.9.0

Q: OS Version
A: Version 22H2 (0S Build 19045.2364)

Q: Docker Desktop Version
A: Docker version 20.10.21, build baeda1f

Q: Were any error codes or messages observed? If so, what were they?
A: “Something bad happened”

Q: Detailed Description of the Problem
A: I Installed Devkinsta just yesterday. When I try to make a WordPress site, I get an error “Something Bad happened.”

ezgif-1-8f309bd1a3

main.log (655.4 KB)

Hello there @a1_mm :wave: Welcome to DevKinsta community!

Thank you for reporting this case and for uploading that main.log file .
I’ve just checked that main.log file and noticed this error message there for example:

[2022-12-16 21:59:11.064] [error] [ipcMainStep] Error in operation SITE_CREATION, step database: Error: Error (1): UERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

and based on the animated screenshot you provided, the “Something Bad happened” happened on the 2nd step that’s “Creating MySQL database” process.

So this sounds like the password for the user “root” does not seem to be correct it seems (and it shows that “Access denied” in the main.log) - I’m not sure what has been done before, as by default the password for root DB access should not be altered/changed.

If you just installed DevKinsta, I assumed you haven’t created any sites yet (and no databases at all), then could you please open the Docker desktop on your Windows and delete the "devkinsta_db" container only (that may look like this - the follow screenshot I took from my Windows 10 pro machine)

Once deleted, please completely close and quit from your DevKinsta as well (make sure it’s not running in the background / not just closed and minimized in the taskbar icon on the bottom right) .

After that, please re-load your DevKinsta and it should recreate that "devkinsta_db" container (and you can re-check your Docker desktop to confirm that "devkinsta_db" container has been re-created/re-setup with the proper root DB password).

Then you can please try to create / setup a new WordPress site with DevKinsta and see if it will be working fine.

Cheers,
Agus