Site Health: REST/loopback requests are failing, scheduled event failed

Q: DevKinsta Version
A: 1.0.1

Q: OS Version
A: Windows 10 Pro 20H2

Q: Docker Desktop Version
A: 3.1.0

Q: Detailed Description of the Problem
A: So I’ve created a new site and decided to check which information is displayed in Site Health report.

I see these 2 critical errors:

And this recommended improvement:

None of these issues present when I use some other (non-docker based) solutions to create sites locally (OSPanel.io, for example).

Thank you for reporting this. I do see those messages on my end too. We’ll take a look at this!

I have exact the same Problem

In my case it will connect to port 80

Excited to use devKinsta but unfortunately, I couldn’t not run any cron which is very important to my project.

Please see the following:

Error: cURL error 7: Failed to connect to website.local port 443: Connection refused (http_request_failed)

Same thing when I’m not using SSL

Same error when using normal PHP Curl

Tools > Site Health > Could not complete a loopback request

I’ve disabled windows defender but didn’t fixed the issue.

Everything is fine when I’m using localwp.

Thanks!

Sorry for the wait here, @josephg . I’m checking with our developers on this and will get back to you shortly.

@michael No worries mate! Thank you so much for looking into this.

Wordpress site health is also giving me:

"“The REST API request failed due to an error.
Error: cURL error 7: Failed to connect to butterfly.local port 443: Connection refused (http_request_failed)”

What does it mean and how do I fix it?

I’m also getting this related error:

"Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.

The loopback request to your site failed, this means features relying on them are not currently working as expected.
Error: cURL error 7: Failed to connect to butterfly.local port 443: Connection refused (http_request_failed)"

I’m sorry for the trouble @kadso . We’ll have this resolved in a future version.