Non-saying error

Is it just remaining stuck on “restarting” every time you check it?
Can you copy the container ID of the devkinsta_nginx container and run this:

docker container rm CONTAINER_ID

After that try starting DK again and see if it remains stuck on “restarting.”

Can you also screenshot your Images page in Docker Desktop? I’d like to compare the versions with mine

Hey @Kevin - I can’t remove the container because it’s stuck on restarting. I can only delete the container in Docker’s UI. But after restarting DevKinsta, I get the same error.

Okay so docker rm devkinsta_nginx didn’t work because it was restarting? Can you follow these steps.

  1. Run this command docker stop devkinsta_nginx
    If that doesn’t work try docker rm -f devkinsta_nginx
    If there are no errors please run docker container list and screenshot what you see. Please screenshot any errors you receive otherwise.

  2. Disable auto restart for Docker containers with this command:
    docker update --restart=no $(docker ps -a -q)
    Please screenshot what this command returns for you.

  3. Now completely stop Docker. The easiest way would be to restart your computer…

  4. Take a screenshot of docker container list after rebooting/BEFORE opening DevKinsta. Is devkisnta_nginx still trying to restart? If it’s not there/not restarting, open DevKinsta to see what happens.

So if the issue isn’t progressing at all run this command: docker logs -f devkinsta_nginx. Please share the log output.

Hi @Kevin - I ran the commands and they were successful. Result:

Step 2:

Step 3: docker container list is empty (all containers are “exited”)

Step 4: docker logs -f devkinsta_nginx returns Error: No such container: devkinsta_nginx

Error still persists:

Okay perfect, now can you restart Devkinsta again and see what happens? You will need to run this command again once devkinsta_nginx starts: docker update --restart=no $(docker ps -a -q)

Okay now while it is failing can you run docker logs -f devkinsta_nginx again?
If nothing happens then docker container list again

Ah okay, that’s very helpful. It looks like one of of SSL certificates is missing for some reason. Can you check ~/DevKinsta/ssl for that odanna-1 crt file? Is it missing there too?

I was able to reproduce that error by deleting my certificates. I’m not sure when/how those were deletec from your computer.
I have asked our developers for a quickfix for this. We basically just need to manually create the ssl certificate. I will contact you once they tell me. Thank you for your patience here @jarno. We’ve never anyone run into this so it’s a brand new error.

Hi @jarno, this is the process the Developers gave me to generate a new certificate so that NGINX can start:

  1. cd ~/DevKinsta/ssl
  2. openssl genrsa 2048 > odonna-1.local.key
  3. openssl req -new -x509 -nodes -sha256 -days 365 -key odonna-1.local.key -out odonna-1.local.crt
  4. Answer anything to the prompt questions until you are asked for the “Common Name”. For this you enter odonna-1.local
  5. With those files created you should delete devkinsta_nginx again before reopening DevKinsta.

It should now get past that error, if it doesn’t please share the logs. Once you get back into DevKinsta, please make sure the site still works without issues. You can also go to that specific site’s page and disable SSL
image

After it is disabled, you can delete the SSL certificate that you manually created. Enabling SSL and HTTPS again should allow DevKinsta to create the certificate for you.

Yes, that worked. Now, I’m encountering the next issue, related to the database. When trying to delete a site, I get a DK0051 error.

I’ve tried to install mysql with Docker:

sudo docker pull mysql/mysql-server:latest

I get this error when I open database manager:

Warning
: Cannot modify header information - headers already sent by (output started at /var/www/html/adminer.php:181) in
/var/www/html/adminer.php
on line
1528


Warning
: Cannot modify header information - headers already sent by (output started at /var/www/html/adminer.php:181) in
/var/www/html/adminer.php
on line
1436

Devkinsta uses Mariadb and not Mysql. You could try deleting the mariadb container and letting DevKinsta recreate it but you will need to send me the main.log for the DK0051 error.

[main.log|attachment]

Do you know why this is happening? Did you change anything with your computer before this started?

Cannot select database The database server could be connected to (which means your username and password is okay) but the database could not be selected.

All of your database connections say “Unknown database.” Did you delete the kinsta database or something? Does your database manager show your databases?

Also, are you trying to delete all of your websites to start over? Or are you only deleting some of them?

One of my sites got stuck on pulling from Kinsta. I tried to delete that site and start the process again, but that led to all of the issues I’m having now.

When I open my database manager, I see the error from the message I sent before the main.log.

Hmm, a single site failing shouldn’t cause this but this might be something new. Can you update to DevKinsta 2.7.0?

Once done please private message your config.json file to me. I’ll see if the database connection information is still correct. You’re config.json will be here for Mac:

User/Library/Application Support/DevKinsta

I just updated to 2.7.0. The issue is in the databases. I still have a full_backup.sql file, containing database info of all my sites. Where can I import this file, so that my databases are restored?

Okay perfect; so you can use the database manager to import the SQL
image
You can import to specific sites

Or just the entire database depending on what your backup SQL contains.

Or if you have a database management application/program you can use the credentials under “Site Info > Database” to connect to your DevKinsta database. It will work the same way as the Database Manager.

I’m getting this error when I open the database manager:

Click on the dropdown and select the blank option. What does that do?
image

The URL will be something like this: http://127.0.0.1:15200/?server=devkinsta_db&username=root&import=