Keep prompting to install docker

In the macos system, Docker has been installed and enabled. After DevKinsta is enabled, it prompts: To use DevKinsta, download and install Docker on your computer. Which friend knows how to solve it?


Hi @salonglong and welcome to DevKinsta Community!
Can you please try to run the following command via terminal when both DevKinsta and Docker are entirely closed?

sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

Once done, try to open DevKinsta as usual.
If this doesn’t help, can you please send me a copy of your main.log file via DM? You can find it by clicking on the Help menu at the top of the screen and then on Reveal log file.


The file(main.log) has been sent to you by private message!

Hi there @salonglong :wave:

Alessandro shared the main.log file to us which you provided to him via private message (DM).
As I could see from the log, I noticed the following - which seems that DevKinsta still can’t find/see the Docker on your local computer:

[2023-05-28 09:25:32.425] [error] watchDocker - Error: connect ECONNREFUSED /var/run/docker.sock


[2023-05-28 09:25:33.231] [error] Error - DK0003: DOCKER_INSTALL_COMMON_ERROR: Docker isn’t installed

Could you please confirm if you have tried the suggestion from Alessandro to run this command via your terminal on your Mac computer?

sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

if you have done that, have you tried to reboot your computer and tried to re-load DevKinsta - if it’s still showing the same prompt - to download/install Docker?

If that so, could you please also open your terminal program on your Mac computer, and try to run the following command lines (1 by 1) and provide us with their output/results - and so we can check for sure:

  1. docker --version
  2. docker version
  3. which docker
  4. docker context ls