DK0029 Error - Unprotected private key file

Hi @Kevin, got it working! Well kinda, haha…

I switched Docker Desktop to WSL2, deleted the .ssh files, let DevKinsta rebuild the containers and logged back in, and I can now download sites again!

Problem is I’m back to having horribly slow load times on the sites, which is the reason I had switched to Hyper-V last summer :confused:

I guess it’s better than not being able to load the sites at all. Hopefully ya’ll can figure out one or both of the issues haha.

1 Like

Ah, thanks for the update @mattd; I’ll definitely do some more DevKinsta developing and try your Hyper-V approach in the future. Will let you know if I ever find a workaround/if our devs make any changes there.

1 Like

Try it again later. If It still doesn’t help, please reach out to us on our support forum.
From source divkinsta

Hi @jackdoe, if you are receiving the same error, can you please private message your main.log file to me? I would also need info on what OS and DevKinsta version you are using.
Thank you!

I’m having the same issue and have tried everything suggested in this thread. I also switched from WSL2 to Hyper-V because of performance issues.

Hi @Adam_Conde, so you run into the exact same issues when using Hyper-V but WSL2 works/is slow, correct?

We’re still not sure what would cause this to stop working but I’ll update in this thread if we find a fix/workaround.

That’s correct. The overall experience using websites in DevKinsta with WSL2 was very slow page loads. So, I switched to Hyper-V and the performance is now so much better. When I initially made the switch, I was able to import a site into DevKinsta, so I can’t say that switching was the cause of the problem I’m having now. But it is interesting because it’s something the original poster also mentioned

Yes @Kevin, I was faced this issue But now I don’t have that file