Disable HTTPS at import?

Fresh DevKinsta install and importing a site from Kinsta staging, the process fails on the last step with the error: DK0024 - Can’t write to Certificate store. The site is accessible without https at http://domain.local though so not a huge deal, except that DevKinsta considers the import to have failed and has all the options disabled (like Open site, Push to staging, etc.). There’s also the SSL and HTTPS option (says SSL update failed) but the toggle input is disabled so I can’t turn it off, probably because the import “failed”.

Is there a way to import a site without HTTPS enabled?

Thanks!

Hey @mattd . It sounds like there might be a permission issue with the SSL certificate being created. Would you happen to have any firewall settings on your machine that could be preventing it from properly being created? At the moment SSL generation is one of the many steps that all imports complete so it’s not possible to disable.

Hi @michael, thanks for the reply.

It’s on a Win 10 computer at work, which does have some restrictions and settings managed by the administrator. I’ve disabled everything I have access to, and running as admin, but it still fails on that final step.

I can manually import the domain.local.crt file into the certificate store, but the DevKinsta app doesn’t pick up on that.

Probably a long shot… but is there a way to make the app think the import was successful? The site is listed under Sites, but only with Retry and Delete options.

Thanks!

Not at the moment but I’ve noted this with the devs to improve this flow.

Ok great, thanks @michael!