Cannot turn off WP_DEBUG after activating. Returns wrong format in wp_config

Q: Date/Time this occurred (Provide your time zone also)
A:

Q: DevKinsta Version
A: 2.2.0

Q: OS Version
A: macOS Big Sur

Q: Docker Desktop Version
A: 4.1.1

Q: Were any error codes or messages observed? If so, what were they?
A: No

Q: Detailed Description of the Problem
A:

When activating WP_DEBUG from DevKinsta UI, it is turned on, but when deactivating the settings returned to wp_config.php file is added with strings instead of f boolean, so the setting is not interpreted.

It works again if you change the settings from:
define( ‘WP_DEBUG’, ‘false’ );
define( ‘WP_DEBUG_LOG’, ‘false’ );
define( ‘WP_DEBUG_DISPLAY’, ‘false’ );
to this:
define( ‘WP_DEBUG’, false );
define( ‘WP_DEBUG_LOG’, false );
define( ‘WP_DEBUG_DISPLAY’, false );

This issue (and fix!) was first reported on the 19th of January here: WP-Config - invalid values for WP_DEBUG defines - #12 by Andrew_Fair

Why is this change not implemented yet??

Regards,
Andreas
Aptum

A post was merged into an existing topic: WP-Config - invalid values for WP_DEBUG defines