Cannot access local dev site

:frowning: I cancelled, and renamed again, still same issue.

Okay, just to simplify things let’s forget renaming for now and go back to the original issue. There’s a new version of DevKinsta coming out soon that may resolve this.

Did you try opening your .local address in a different browser/incognito? Does it still redirect?

If you check the database, are the site_url and home_url in wp_options showing the .local address?

If you are being redirected to the Staging URL, the URL must be present somewhere. If it isn’t being cached in your browser, then it must still be in the database or the site files.

Not sure how to even check the database, because I can’t access anything, because I’m stuck in a loop.

I cannot cancel the renaming, and so it won’t allow me to do anything.

(And yes, I checked the local URL in incognito - no luck)

Oh sorry, I though it eventually got past that state.

If cancelling isn’t working, you can force clear the running state by editing your config.json file. I’ve explained it here.

On Mac, config.json should be in the User/Library/Application Support/DevKinsta folder

Hi Kevin,

I checked the database and it shows the local url, but yet still points to staging…

Huh, this really doesn’t make sense. It feels like it has to be coming from your browser then since there’s nothing in the database or your files that should send you back to Staging.

Can you use Chrome DevTools to see what the headers on the redirect are?

You need to open a brand new window → open DevTools → click on the Network Tab and tick the “Disable Cache” box

Now navigate to your .local address in the browser. If it still redirects you’ll see something similar to this

Click on the the request that has a 302 or 301 status and look at the response headers. If you can screenshot those response headers it will at least give us some idea of where the redirect is coming from.

oh sweet baby jesus, it’s working. I shut my machine down last night after work, so perhaps that really forced the cache to clear. (I swear I was doing incognito/private browsing yesterday!!!)

I feel totally crazy, but happy it’s now working. Appreciate your support. :pray:

1 Like

Awesome, I’m just glad it’s working! You’re very welcome!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.