403 Forbidden (nginx) error - (reverse proxy)

Hi,
I had installed devkinsta well. Then I imported the website from kinsta.

But I get a 403 Forbidden error, can not open the website and the wpadmin page.

My website is a reverse proxy website. I want to know if this reverse proxy is related? What do I need to do? Thank you

The location of the real root directory of my local file:

Users\example\DevKinsta\public\examplecn\cn\wp-admin

devkinsta site host:
://examplecn.local/

thanks

Hi @lucas7c ! I’m happy to help. Yeah, due to it being a reverse proxy, unfortunately it’ll require a few additional configurations here for it to work. This may not be ideal as any edits made the nginx configuration will reset on any restarts/shutdowns/upgrades thus having to make those configurations again. There is a feature request here for the ability to edit nginx easily.

If you’re interested in editing nginx, we have a post here that might help with that. Essentially you’ll need to change the root directory on nginx to load from the reverse proxy sub-directory. Additionally, you’ll need to add rewrite ^/subsite-will-load-here/(.*)$ /$1 last; within nginx to ensure it loads from the sub-directory.

Let me know if you have any questions along the way on setting this up.

Thank you very much for your reply, I will try it tomorrow. Thank you.